AR sight/alignment question

Iggie

Active Member
I have a 16" AR with a 15" MWI rail and YHM quick deploy sights. Front sight sits on the end of the rail, rear sight sits behind a Bushnell TRS red dot on the rear of the receiver. The rifle will give consistent groups with quality ammo. However, My sights wont quite line up with POI. The rear sight is adjusted all the way left. Does anyone know what kind of issues will cause this?
 

Jackary

Active Member
Are you shooting free hand or off of a rest? Is the rail lined up properly? Does point of aim and impact match up through the red dot? What range are you shooting at? If you are talking about your irons lining up for your dot they should be sighted in separately and might not line up when both are zeroed. Not sure if any of that helps but those could be some of the issues.
 

Iggie

Active Member
I shortly afterwards discovered the issue. the center of the rail was lining up with the left side of the barrel. I was able to adjust this somewhat and correct the issue. basically the irons would not sight in on POI, from any position. The rail appeared to be lined up, but had been bent. I assume this is due to my own monkey wrenching. The irons now lower 1/3 co-witness with the red dot while the front sight is not completely centered I was able to improve it. After a bit of searching MWI no longer offers that specific rail, probably due to this issue if I had to guess. The rail aligns with 4 tiny tabs and two are now bent up and out slightly. This was enough to create 1/4 to 1/2 inch deflection at the end of a 15" rail. I intend to message MWI just to see if its a known issue and if there is a known fix.
 

Latest posts

Top